Lords Mobile Today: 0    Total Posts: 69

Total:#39

Create Thread

[Update Notes] Version 1.37 (Mar 7th Update)

Hot Topics [Copy link] 38/9073

#31
Posted on 2017-03-07 12:00:40 | Show thread starter's posts only

Same thing here. It has started me over, I hope they have an answer soon for this

Signature
#32
Posted on 2017-03-07 12:35:48 | Show thread starter's posts only

can login into game, but when opening new, i get IGGID not found ... guess no new for me.

Signature
#33
Posted on 2017-03-07 12:51:59 | Show thread starter's posts only

Hey Guys. There was a major bug with the latest update. I had reinstalled the game last night when prompted and after the system updates were done, my castle had been reset. The fix was to once again, uninstall and reinstall the game. The old castle then returned. Thank goodness. 9 months of work getting to lvl25 and over 200k troops. :) Good luck to everyone else.

Signature
#34
Posted on 2017-03-07 12:58:40 | Show thread starter's posts only

Signature
r bowman
#35
Posted on 2017-03-07 12:59:57 | Show thread starter's posts only

Signature
r bowman
#36
Posted on 2017-03-07 13:39:02 | Show thread starter's posts only

This right here is why I will not spend another penny. Fix this crap! 8h shield minimum for all after a maintenance that lasts longer than your first posted time frame IGG!
You think those gems covered the cash he invested?

Signature
#37
Posted on 2017-03-09 14:54:15 | Show thread starter's posts only

My game will not load, just stays in the title screen with the spinning wheel. The live support option does not load.

Signature
#38
Posted on 2017-03-17 22:14:36 | Show thread starter's posts only

Wow the latest update version  many thanks LM hope the Darknest is gone time for a new event.

Signature
#39
Posted on 2017-04-04 13:12:51 | Show thread starter's posts only

Im a having a problem to reinstall the appbon my iphone.... i need help

Signature
Johnd